Existing Values Autocomplete Widget - Critical - Access bypass - SA-CONTRIB-2019-060

2019-07-30
Critical
拡張モジュール

2019/7/24(日本時間:GMT+9)、拡張モジュールにおいて脆弱性が発見されました。
インストールしているDrupalの導入モジュールを確認のうえ、必要な場合はアップデートをおすすめします。

●プロジェクト :Existing Values Autocomplete Widget
●投稿日 :2019/7/24
●セキュリティリスク : Critical
●脆弱性 :Access bypass

==概要==
このモジュールはテキストフィールドのためのオートコンプリートウィジェットをすることができます。オートコンプリートウィジェットはフィールドのすべての既存の(以前に入力された)値を提案します。

またこのモジュールは、オートコンプリート結果を返す前に適切なアクセス許可を十分に確認することができません。

この脆弱性は、攻撃者がオートコンプリートコールバックコントローラへのルートを知っているため発生します。

==解決方法==。
最新版をインストールしてください。

Drupal 8.x用の既存値オートコンプリートウィジェットモジュールを使用している場合は、 オートコンプリートウィジェット8.x-1.2にアップグレードしてください。

Existing Values Autocomplete Widgetプロジェクトページも参照してください。

==元記事==
https://www.drupal.org/sa-contrib-2019-060