【セキュリティー情報】DrupalChat - Critical - Multiple vulnerabilities - SA-CONTRIB-2017-057

Submitted by drupal-kanri on 金, 07/07/2017 - 06:48

2017年7月5日(日本時間:GMT+9)、拡張モジュールにおいて脆弱性が発見されました。
インストールしているDrupalの導入モジュールを確認のうえ、必要な場合はアップデートをおすすめします。

●勧告ID : DRUPAL-SA-CONTRIB-2017-057
●プロジェクト :DrupalChat (拡張モジュール)
●バージョン : 7.x
●投稿日 :2017/7/05
●セキュリティリスク : Critical
●脆弱性 : Cross Site Scripting, Cross Site Request Forgery

==概要==
DrupalChat拡張モジュールはDrupalサイト訪問者同士のチャット機能、またはチャットルームを提供します。
本モジュールはチャットリクエストの有効性を十分に確認しない結果、CSRFの脆弱性が発生します。
本脆弱性によって攻撃者はユーザを任意ユーザに任意のメッセージを送らせる恐れがあります。
本モジュールは管理者によって提供されたテキストを分析しないため、XSSの脆弱性も発生しました。

==影響を受けるバージョン==
DrupalChat拡張モジュール7.x-2.6バージョン以下の7.x-2.xのバージョンです。

Drupalコアには影響がありません。
DrupalChat拡張モジュールを使用していない場合は、何もする必要はありません。

==解決方法==。
Drupal 7.x用のDrupalChat拡張モジュールを使用している場合7.x-2.6はバージョンにアップグレードをお勧めします。

より詳しい説明はhttps://www.drupal.org/project/drupalchat をご覧ください。

==元記事==
https://www.drupal.org/node/2892404